On Tue, 7 Nov 2000, [iso-8859-1] Aleksi Niemelwrote:

> matz queries:
> > If we can find better name, 
> 
> How about default, defaults or defaulting (I like the last).

I'd call it "nilGives" or "nil_gives", etc.  I think default leaves too
much open -- it depends on how your objects are made as to what their
defualt value is.

This reminds me of my request for a short-circuit operator....  Is
there a way the two can be unified, or is that silly?

	Hugh
	hgs / dmu.ac.uk