Hi

I have installed on FreeBSD and Sun with no problems.
Since it works on the other OS's and it makes it 
through config and setup, it may be a setup.rb problem.

Installing on MacOSX (ruby 173) gives the following
error:

% ruby -v
ruby 1.7.3 (2002-12-19) [powerpc-darwin5.5]
% ruby setup.rb install
setup.rb: entering install phase...
---> packages
---> packages/runit-compat
---> lib
mkdir -p /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/
install rubyunit.rb /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/
---> lib/runit
mkdir -p /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
install assert.rb /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
install error.rb /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
install testcase.rb /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
install testresult.rb /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
install testsuite.rb /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
install testunit-installed
/Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
install topublic.rb /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit
---> lib/runit/cui
mkdir -p /Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit/cui
install testrunner.rb
/Users/jdf/ruby173/lib/ruby/site_ruby/1.7/runit/cui
<--- lib/runit/cui
<--- lib/runit
<--- lib
<--- packages/runit-compat
---> packages/testunit
---> lib
Loaded suite TS_TestUnit
Started
...
Failure!!!
test_suite(Test::Unit::TC_TestCase):
Should have had one test failure
..
install failed
hook
/Users/jdf/downloads/ruby/testunit-0.1.5/packages/testunit/lib/pre-install.rb
failed:
stack level too deep
try 'ruby setup.rb --help' for usage


-- 
Jim Freeze
----------
Harris's Lament:
	All the good ones are taken.