[snipped lots of good args by kent and martin]

maybe we can name methods by the way we access them (and not on its form).
top/bottom are too generic/ambiguous since we can turn array upside-down
anytime :-)
 
try fifo/lifo. so we have fifo#in, fifo#out, lifo#in, lifo#out...