Hi

I found some postings regarding my problem dating from July 2002 in 
the ruby mailing list archive but no solution that worked for me. I 
was yet not able to install mysql-ruby on a OSX/darwin System.

I have a system with mysql from fink (

mysql  Ver 11.18 Distrib 3.23.53, for apple-darwin6.2 (powerpc)
/usr/include/mysql/mysql.h
/sw/lib/mysql/libmysqlclient.10.0.0.dylib

) and a system with the mysql that came with MacOSX Server (

mysql  Ver 11.18 Distrib 3.23.51, for apple-darwin6.0 (powerpc)
/usr/include/mysql/mysql.h
/usr/lib/mysql/libmysqlclient.a

). On both systems I didn't have yet any success compiling the 
mysql-ruby stuff, with no variation of the '--with-mysql-lib' and 
'--with-mysql-include' arguments.

mysql-ruby: v 2.4.3
ruby: 1.6.7

Any ideas?

Regards

Beat H. Birkhofer