On Thu, Nov 14, 2002 at 02:43:30AM +0900, Paul Brannan wrote:
> [pbrannan@zaphod uilib]$ irb
> Rirb(main):001:0> RUBY_VERSION
> "1.6.7"
> irb(main):002:0> Math.log(0); 1.2345
> 1.2345
> irb(main):003:0> Math.log(0); 1.2345
> (irb):3: warning: Float 1.2345 out of range
> 1.2345

????

batsman@tux-chan:~$ irb
irb(main):001:0> RUBY_VERSION
"1.6.7"
irb(main):002:0> Math.log(0); 1.2345
1.2345
irb(main):003:0> Math.log(0); 1.2345
1.2345
irb(main):004:0> Math.log(0); 1.2345
1.2345
 
batsman@tux-chan:~$ irb1.7
irb(main):001:0> RUBY_VERSION
"1.7.2"
irb(main):002:0> Math.log(0); 1.2345
1.2345
irb(main):003:0> Math.log(0); 1.2345
1.2345
irb(main):004:0> Math.log(0); 1.2345
1.2345
irb(main):005:0> Math.log(0); 1.2345
1.2345
irb(main):006:0> Math.log(0); 1.2345
1.2345

> [pbrannan@zaphod uilib]$ ruby-1.7 `which irb`
> irb(main):001:0> RUBY_VERSION
> "1.7.3"
> irb(main):002:0> Math.log(0); 1.2345
> 1.2345
> irb(main):003:0> Math.log(0); 1.2345
> 1.2345
> irb(main):004:0> Math.log(0); 1.2345
> 1.2345
> irb(main):005:0> Math.log(0); 1.2345
> 1.2345
> 
> Any ideas why this is happening?
> 
> I found [ruby-talk:36449], where the author said he saw something
> similar happen under 1.7.2 but not under 1.6.7.  There were no
> responses, though.
> 
> Paul
> 

-- 
 _           _                             
| |__   __ _| |_ ___ _ __ ___   __ _ _ __  
| '_ \ / _` | __/ __| '_ ` _ \ / _` | '_ \ 
| |_) | (_| | |_\__ \ | | | | | (_| | | | |
|_.__/ \__,_|\__|___/_| |_| |_|\__,_|_| |_|
	Running Debian GNU/Linux Sid (unstable)
batsman dot geo at yahoo dot com

*** Rince is wagner / schizo.DAINet.de (We have Joey, we have Fun, we have Linux on a Sun)
	-- Seen on #Debian