Okay, I've finally managed to install the ruby mysql driver, but now, every
time a script requires 'mysql', it produces the following warnings:

/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_MIN_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_MAX_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_UNKNOWN_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_SOCKET_CREATE_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_CONNECTION_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_CONN_HOST_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_IPSOCK_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_UNKNOWN_HOST
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_SERVER_GONE_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_VERSION_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_OUT_OF_MEMORY
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_WRONG_HOST_INFO
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_LOCALHOST_CONNECTION
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_TCP_CONNECTION
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_SERVER_HANDSHAKE_ERR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_SERVER_LOST
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_COMMANDS_OUT_OF_SYNC
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_NAMEDPIPE_CONNECTION
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_NAMEDPIPEWAIT_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_NAMEDPIPEOPEN_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_NAMEDPIPESETSTATE_ERROR
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_CANT_READ_CHARSET
/usr/local/lib/ruby/site_ruby/1.6/DBD/Mysql/Mysql.rb:33: warning: already
initialized constant CR_NET_PACKET_TOO_LARGE

Anyone know how to get rid of this?

Thanks,
Carl