Hello

I'm trying install IOWA on my computer, but I'm not successfull.
I use the latest ruby grabbed from cvs.  This is compilled with
$ autoconf
$ ./configure --prefix=$HOME
$ make
$ make test
$ make install

As you can see, I install ruby to my home to don't touch the system.

Next I compiled IOWA
$ make
$ su root make install
$ ruby install.rb

Then I've make corrections to /etc/init.d/apache.  I inserted
/home/radek/bin directory just after /bin in PATH just be sure.

Edit /etc/apache/httpd.conf
LoadModule action_module /usr/lib/apache/1.3/mod_actions.so
LoadModule iowa_module   /usr/lib/apache/1.3/mod_iowa.so
Action iowa /cgi-bin/iowa.cgi
<Location /iowa>
        SetHandler iowa
        Order   allow,deny
        Allow   from all
</Location>

I also handly copied the iowa.cgi to /usr/lib/cgi-bin directory and
modified first line to use my ruby
#!/home/radek/bin/ruby

After restarting apache
$ su root /etc/init.d/apache restart
and running iowa in guestbook directory in exmaples
$ ruby guestbook.rb

I take a look at the web page
$ lynx -mime_header http://loclahost:8080/iowa/guestbook

And on the console where I run the guestbook.rb I see this
/home/radek/lib/ruby/site_ruby/iowa/BindingsParser.rb:38: warning: parenthesize argument(s) for future version
listening on /tmp/iowa_guestbook
radek@kvark:~/source/iowa-0.15/examples/guestbook$ incompatible marshal file format (can't be read)
        format version 4.8 required; 15.47 given

I'm confused with this error.  Looking in the source of latest cvs
version I see that marshal format version is 4.8, the ruby expect
this.  But from where is the version 15.47.

Can anoyne help me?

-- 
Radek Hnilica <Radek at Hnilica dot CZ>
=======================================
No matter how far down the wrong road you've gone, turn back.
						Turkish proverb