If you have OSX can you tell me what version of Ruby is installed? Also have
you tried getting the latest to run (1.7.3)? Problems there?

I ask because I may go to that platform.  : )

Bob