> |Does anyone but me like this proposal at all?
> I don't know.  I personally don't feel it's required.  But I can find
> the room for the syntax (maybe; I should try first).  If *many*
> requested this enhancement, we can add it to the language after
> deciding 1) operator priority 2) the name of the internal method.
> In [ruby-talk:5125], matju proposed candidate for both.

In 5125, I did propose a precedence, but did not explicitly proposed a
name for the internal method. However, I feel "a in b" should mean
"b.include? a", just like the original poster had said.

maybe contains? would be a better name (?), but if it were, "contains?" 
would have to become the official name for "include?".

Disclaimer: I've never used the "for..in" statement in ruby. :-)

matju