matz / ruby-lang.org (Yukihiro Matsumoto) wrote in message news:<1032480831.688890.8657.nullmailer / picachu.netlab.jp>...
> 
> We want to have a new method to replace "indices", because of
> inconsistency between "indices" (or "indexes") and "index". "index"
> returns index of a value, "indices" returns values corresponding to
> indices.

Has anyone suggested 'values'? array.values(1,2,3) sounds reasonably
natural, as does hash.values(key1, key2, key3).

martin