----- Original Message ----- 
From: "Yukihiro Matsumoto" <matz / ruby-lang.org>
To: "ruby-talk ML" <ruby-talk / ruby-lang.org>
Sent: Saturday, September 21, 2002 9:25 AM
Subject: Re: select and select


> Hi,
> 
> In message "Re: select and select"
>     on 02/09/20, Joel VanderWerf <vjoel / PATH.Berkeley.EDU> writes:
> 
> |What about these?
> |
> |   at_indices   (too long, ugly)
> |   sample       (not very clear)
> |   pick         (too close to select)
> 
> I like "pick".  How do others feel (especially English speaking ones)?

It's OK, but I think not ideal...

If the motivation is the conceptual conflict between
"index" and "indices" (they're named nisleadingly 
similarly but do opposite things) then I think
I would do the reverse: Change "index" to "find_index"
(which is clearer anyway).

But there is probably some good reason not to do this.

Hal