Hi --

On Sun, 22 Sep 2002, Yukihiro Matsumoto wrote:

> Hi,
>
> In message "Re: select and select"
>     on 02/09/22, Dave Thomas <Dave / PragmaticProgrammer.com> writes:
>
> |> What about a 'pick_as' option for the hash?
> |
> |Perhaps pick_using_xxxx, with straight 'pick' as an alias for
> |pick_using_key
>
> pick_by_key(s)?

I would put it in the plural.  Presumably h.pick_by_keys(:akey) would
be quite rare (just a long way of saying h[:akey]).  And if it's in
a variable (pick_by_keys(*some_keys)) it looks and feels plural, even
if the array happens to have only one element.


David

-- 
David Alan Black                      | Register for RubyConf 2002!
home: dblack / candle.superlink.net     | November 1-3
work: blackdav / shu.edu                | Seattle, WA, USA
Web:  http://pirate.shu.edu/~blackdav | http://www.rubyconf.com