Tom Sawyer wrote:
> "elements" would probably be "proper". but "items" works well too. i'll
> throw in my +1. its more intuitive.

Hm, "items", "elements", and "entries" all seem to fit in the same box 
in my brain, but "entries" already has a meaning in Enumerable#entries.

Would it make sense to have

   [0,1,2,3,4].entries         #==> [0,1,2,3,4]

and at the same time

   [0,1,2,3,4].items(1,3)      #==> [1,3]

or would this be confusing?

What would the value of

   [0,1,2,3,4].items

be? All, or nothing?

For me, the confusion is using two words that I don't distinguish in 
meaning for two slightly different, but related operations.

Would it be less confusing to extend the behavior of #entries, instead, 
like this:

   [0,1,2,3,4].entries(1,3)    #==> [1,3]

or would this lead to the same problems as with overloading #select?