Hello --

I'd like to suggest (again, but the first time it was buried in
another thread :-) that the new dual nature of "select" is kind of
awkward, and I'm wondering whether it's been finalized.

I've always thought of select as a condition-based filter.  I guess
one could argue that indexes are a condition... but it feels to me
like "select" is getting overloaded in a way that isn't necessary.

In one case, I found myself writing:

  select(*[i+n,i-n].select{|x| x > 0})

where the dual nature of select really comes through in (to me) a
strange way.  I know it could be rewritten; I'm just not clear wher
the advantage of (or necessity for) using the same name for two things
comes from.  Wouldn't allowing #at to take multiple arguments be
cleaner?


David

-- 
David Alan Black                      | Register for RubyConf 2002!
home: dblack / candle.superlink.net     | November 1-3
work: blackdav / shu.edu                | Seattle, WA, USA
Web:  http://pirate.shu.edu/~blackdav | http://www.rubyconf.com