Not sure where to report this, but I used the version from

http://www.pragmaticprogrammer.com/ruby/downloads/ruby-install.html

There is a problem with 1.7.2 as shown below. I downloaded the 1.6.7 
version and it was fine with the same code. Seems to be Ruby problem 
rather than the installer.


C:\apps\ZenWeb-2.11.0\ZenWeb>ruby -v
ruby 1.7.2 (2002-07-02) [i386-mswin32]

C:\apps\ZenWeb-2.11.0\ZenWeb>
C:\apps\ZenWeb-2.11.0\ZenWeb>
C:\apps\ZenWeb-2.11.0\ZenWeb>
C:\apps\ZenWeb-2.11.0\ZenWeb>
C:\apps\ZenWeb-2.11.0\ZenWeb>
C:\apps\ZenWeb-2.11.0\ZenWeb>
C:\apps\ZenWeb-2.11.0\ZenWeb>ruby RubyCodeRenderer.rb
RubyCodeRenderer.rb:26: syntax error
    content = text.split(/#{$\/}#{$\/}+/)
                                ^
RubyCodeRenderer.rb:51: syntax error
          $stderr.puts "xmp: #{something}\nTrace =\n#{$@.join(\"\n\")}
\n"
                                                               ^
RubyCodeRenderer.rb:52: syntax error
RubyCodeRenderer.rb:55: syntax error
RubyCodeRenderer.rb:60: syntax error
    @result = @result.join("\n").scan(/^.*[\n\r]+/)
                             ^
RubyCodeRenderer.rb:60: unterminated string meets end of file
RubyCodeRenderer.rb:60: syntax error

-------------
Robert Cowham