On Fri, Jul 19, 2002 at 06:30:19AM +0900, Bob X wrote:
> Rich Kilmer wrote:
> >Because the package name represents a file name which could have spaces,
> >etc.
> >
> >Assuming:
> >
> >"my cool ruby library.rb"
> >
> >you would have:
> >
> >require 'my cool ruby library'
> >
> >So this would be problematic:
> >
> >require my cool ruby library
> >
> >-rich
> 
> Er...well Python and Perl (and I think Tcl) do not seem to have this worry?

% tclsh
% package require Cool Package
expected version number but got "Package"
% 

-Martin