Noah Meehan wrote:
> Can someone say what the minimum alternative is to my
> "Ruby1.6.6windowsFullInstall.exe" that I seem to have
> lucked into, and where to get it?

Do you need Ruby 1.6.7 or would version 1.6.6 be good enough? If the 
latter is OK you might want to consider using Andy Hunt's installer for 
Windows instead:

	http://dev.rubycentral.com/downloads/files/ruby166-0.exe

There is also what I believe is an alpha release of his installer for 
Ruby 1.6.7 here:

	http://www.rubygarden.org/ruby?WindowsInstaller

Hope this helps,

Lyle