Hello,

I just upgraded my ruby version to ruby 1.6.7 (2002-07-11) 
[i386-freebsd4] and the following code now raises a SyntaxError exception:

-----------------------
a = [0,1,2,3]
str = "#{a.join("\n")}"
-----------------------

The earlier snapshot from 2002-05-23 worked.

Is this change intentional, or is this a new parser bug that was introduced?

Thanks,
-Brad