Hugh Sasse Staff Elec Eng <hgs / dmu.ac.uk> writes:

> This seems useful to me.  The only thing I see missing from this is
> 
> We want version 1.3.4 or newer, but we know that we don't want
> 1.3.8, because that only lasted 6 hours until the bug (that slipped
> throgh the regression tests) breaking earlier working code was
> found.  But we don't want to force users of 1.3.{4,5,6,7} to
> upgrade.


A while back we had a thread where I suggested a kind of super-require 
that would go and fetch packages automatically on request, but this
was generally thought to be a bad idea. The stuff I'm suggesting here
doesn't do that; it simply uses whatever it finds in your RUBYPATH,
just as 'require' does now.

So, if 1.3.8 has a bug, and you happened to be unlucky enough to
download it for the 6 hours it was available, I guess you download
1.3.9 and the problem goes away. I don't see how else we can do it: we 
can't assume we're online, so we can't go query the RAA, and previous
versions of a package can't predict that 1.3.8 will be a bad-un.

Or am I (yet again) missing the point?


Regards


Dave