> Script started on Fri 05 Jul 2002 16:25:35 BST
> neelix hgs 11 %> cat ruby_bug
> /usr/local/bin/ruby --version
> /usr/local/bin/ruby -e 'require "net/smtp"'
> 
> neelix hgs 12 %> sh ruby_bug
> ruby 1.6.7 (2002-03-01) [sparc-solaris2.7]
> /usr/local/lib/ruby/1.6/net/smtp.rb:216:in `require': No such file to load -- digest/md5 (LoadError)
> 	from /usr/local/lib/ruby/1.6/net/smtp.rb:216
> 	from -e:1:in `require'
> 	from -e:1
> neelix hgs 13 %> exit
> neelix hgs 14 %>
> script done on Fri 05 Jul 2002 16:25:50 BST
> 
> So this is with the latest stable ruby but I do have (results of find,
> remove Perl etc refs):
> 
> /usr/local/lib/ruby/1.4/sparc-solaris2.7/md5.so
> /usr/local/lib/ruby/1.6/sparc-solaris2.7/md5.so
> 
> So I have the md5 modules, but not in a digest dir.  Searching with
> Google for more info on this, I find it came up with 1.6.5, but the
> information about this is in Japanese, so I don't know what was done.
> 
> The ext/digest directory in the Source tree seems to have been made
> successfully.  How should I proceed?

It's odd that md5.so isn't in a digest directory.  I'd suggest
upgrading, but you seem to be running a current version.  It's odd
that Digest::MD5 isn't installed.  Plain 'MD5' has been
depreciated/removed due to conflicting method names with external
libraries.  That said, what are the odds of you trying to upgrade to
the latest 1.6?  Something tells me your install is wonky. -sc


-- 
Sean Chittenden