After downloading, unzipping, etc., configure seemed to work fine, but make failed as follows:

[localhost:~/Temporary/FTP downloads/ruby-1.6.7] bhobbs% make
gcc -g -O2 -fno-common -pipe -no-precomp -I. -I. -I/usr/local/include -c array.c
gcc -g -O2 -fno-common -pipe -no-precomp -I. -I. -I/usr/local/include -c bignum.c
gcc -g -O2 -fno-common -pipe -no-precomp -I. -I. -I/usr/local/include -c class.c
gcc -g -O2 -fno-common -pipe -no-precomp -I. -I. -I/usr/local/include -c compar.c
gcc -g -O2 -fno-common -pipe -no-precomp -I. -I. -I/usr/local/include -c dir.c
gcc -g -O2 -fno-common -pipe -no-precomp -I. -I. -I/usr/local/include -c dln.c
dln.c:1091: header file 'dlfcn.h' not found
cpp-precomp: warning: errors during smart preprocessing, retrying in basic mode
make: *** [dln.o] Error 1
==========
I'm running Mac OS X 10.1.5 on a TiPB/500Mhz/1GB RAM/almost 2GB free disc space.

Incidentally, attempting to execute autoconf results in the following:

FATAL ERROR: Autoconf version 2.50 or higher is required for this script

Can anyone point me in the right direction? TIA!
-- 
Bruce Hobbs, CDP     856 N Monterey St            Phone:  626-570-8028
Partner              Alhambra, CA 91801-1574      Cell:   626-278-0273
Engineered Software  brucehobbs / engineeredsw.com  FAX:    208-474-0732