Hi folks,

We are using fiber with eventmachine (em-synchrony) in our production
env for quite a long time, and it works very well. We use the outdated
ruby 1.9.3 and ActiveRecord 3.x for over 2 years. We are migrating those
two big parts to the latest versions.

When trying to upgrade ruby to the latest, we got an exception `fiber
called across stack rewinding barrier (FiberError)` in 2.0+, but not in
1.9.3. Can you guys help us to figure out this problem?

Sample codes are in this repo:

https://github.com/qqshfox/test_fiber

Any help would be appreciated!

Thanks,
Hanfei