Thanks for all this hard work!

On Fri, Sep 19, 2014 at 7:04 PM, Luis Lavena <luislavena / gmail.com> wrote:

> I'm very pleased to announce the release of RubyInstaller packages for Ruby
> 2.1.3
>
> Installers and 7z binary packages are available from bintray.com:
>
> http://rubyinstaller.org/downloads
>
> https://bintray.com/oneclick/rubyinstaller/rubyinstaller/2.1.2
>
> ## Ruby 2.1.3
>
> This new version of Ruby also brings new changes to RubyInstaller.
>
> Similar to 2.0.0, the packages will be provided in two versions:
> 32bits (x86) and 64bits (x64).
>
> This is possible thanks to newer compiler provided by mingw-w64 project.
>
> Same DevKit used for version 2.0.0 is required for this version.
>
> ### Important information
>
> Please note that the installers in this release are *not digitally signed*.
>
> You can read more about this in post at RubyInstaller group:
> https://groups.google.com/d/topic/rubyinstaller/NhAqcepQ-Xw/discussion
>
> #### Choosing 32bits vs 64bits
>
> Before you download a 64bits version (labeled x64), it is important you
> understand that not all gems, libraries or tools have been tested for this
> version.
>
> It is our recommendation you use 32bits until these issues are solved.
>
> If you have a 64bits version of Windows, you can still use 32bits, as there
> is no performance issue around it.
>
> #### Ruby 2.1.x is brand new
>
> While officially 2.1.x is stable, that doesn't mean all the software will
> magically work on it.
>
> Use 2.1.3 for development and verify your application, scripts and tools
> works
> properly before deciding to run this in your production environment.
>
> #### Existing pre-compiled gems might not be Ruby 2.0 compatible
>
> Ruby 2.1 introduces ABI breakage which means compiled C extensions with
> previous
> 1.9.3 or 2.0.0 will not run against Ruby 2.1.
>
> **DO NOT install Ruby 2.1 on top of existing Ruby 1.9.3 or 2.0.0**, or try
> to
> use compiled extensions with it.
>
> You will be required to force compilation of those gems:
>
>     gem install <name> --platform=ruby
>
> This **will require you have the extra dependencies installed** for that
> gem to
> compile. Look at the gem documentation for the requirements.
>
> Please check each gem documentation and recent releases.
>
> #### Do not use other DevKit version than the one recommended
>
> This version of Ruby has been compiled and optimized for mingw-w64 GCC
> 4.7.2.
>
> Use of another version of DevKit package to compile gems might result in
> compilation issues during gem installation or simply segfaults.
>
> Look for the DevKit installers identified with the name
> 'DevKit-mingw64-32' and
> 'DevKit-mingw64-64' for 32 and 64 bits respectively.
>
> To be clear:
>
> * Download and install `DevKit-mingw64-32-4.7.2` for 32bits Ruby
> * Download and install `DevKit-mingw64-64-4.7.2` for 64bits Ruby
>
> **Known Issues**
>
> There are some issues with Development Kit configuration process that fails
> to detect x64 installations of Ruby. You will need to manually edit
> `config.yml` for it to work. See the following issues for details:
>
> - https://github.com/oneclick/rubyinstaller/issues/221
> - https://github.com/oneclick/rubyinstaller/pull/237
>
> ### MD5:
>
>     594509a374a48fe05598ec203c62f782 *ruby-2.1.3-doc-chm.7z
>     60e39aaab140c3a22abdc04ec2017968 *ruby-2.1.3-i386-mingw32.7z
>     d339f956db4d4b1e8a30ac3e33014844 *ruby-2.1.3-x64-mingw32.7z
>     e5e2c028d76895e9da6c3c86965fc747 *rubyinstaller-2.1.3.exe
>     0f29131a6852cf92382c082eaf1dfd34 *rubyinstaller-2.1.3-x64.exe
>
> ### Official Announcement:
>
> https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
>
> ### Enhancements:
>
> * Upgraded Ruby 2.1 to version 2.1.3
> * Upgraded OpenSSL to version 1.0.0n
> * Upgraded zlib to version 1.2.8
>
> --
> Luis Lavena
> AREA 17
> -
> Perfection in design is achieved not when there is nothing more to add,
> but rather when there is nothing more to take away.
> Antoine de Saint-Exupry
>