Looks like cl.exe cannot be found. You should use vcvarsall.bat to =
configure your path properly.

http://msdn.microsoft.com/en-us/library/x4d2c09s.aspx

On Aug 27, 2014, at 5:47 PM, Moi Me <Julesss2 / hotmail.com> wrote:

> Hello, i would like a hand to understand what's wrong with what i'm =
doing to compile ruby with VS12.
>=20
> When i run .\win32\configure.bat from powershell in the source =
folder,i get the error=20
>=20
> NMAKE : fatal error U1077: 'cl' : return code '0x2'
>=20
> since NMAKE started, it confirms my path works (as cl and NMAKE are in =
the same folder)
>=20
> =46rom Microsoft's documentation, 0x2 is a "missing file" error, but =
path of the potential missing file isn't specified, from there, i don't =
really know where to start searching as the missing file isn't =
specified.
>=20
> To save some time, here's my PATH
>=20
> =
%SystemRoot%\system32\WindowsPowerShell\v1.0\;C:\Windows\system32;C:\Windo=
ws;C:\Windows\System32\Wbem;C:\SysinternalsSuite\;C:\Program =
Files\Microsoft\Web Platform =
installer\;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files =
(x86)\GNU\GnuPG\pub;C:\Program Files (x86)\Git\cmd;C:\Program Files =
(x86)\Windows Kits\8.1\Windows Performance Toolkit\;C:\Program =
Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files =
(x86)\Microsoft SDKs\TypeScript\1.0\;C:\Program =
Files\Perl\bin;C:\Program Files\OpenSSL\bin;C:\Program Files =
(x86)\Microsoft Visual Studio 12.0\Common7\IDE;C:\Program Files =
(x86)\Microsoft Visual Studio 12.0\VC\bin;C:\Program Files =
(x86)\Microsoft SDKs\Windows\v7.1A\Bin
>=20
> My LIB=20
>=20
> C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A\Bin;C:\Program =
Files (x86)\Microsoft Visual Studio 12.0\VC\lib;
>=20
> My INCLUDE
>=20
> C:\Program Files (x86)\Microsoft Visual Studio =
12.0\VC\include;C:\Program Files (x86)\Microsoft =
SDKs\Windows\v7.1A\Include
>=20
> Please don't redirect me to MinGW or tools using it as it won't help =
me understand why it didn't work with VS12
>=20
> Thanks