Dear Raf Ri,

One more thing, did you try to run the ruby code from terminal?

Please see if it finds the gem when running from terminal, so we could
isolate it as an aptana issue.

One more thing to do is to run this _inside_ a ruby script inside
Aptana. Just to see if Aptana is running the scripts in a different
enviroment than your terminal.

#!/usr/bin/env ruby

commands =3D
  [ "which ruby",
    "which gem",
    "rvm list",
    "gem list | grep rubygame",
    "env | grep -i ruby" ]

commands.each do |cmd|
  puts ">> Running: #{cmd}"
  puts `#{cmd}`
  puts
end

Best regards,
Abinoam Jr.

On Thu, Feb 6, 2014 at 6:03 AM, Abinoam Jr. <abinoam / gmail.com> wrote:
> Dear Raf Ri,
>
> The problem raises _only_ with rubygame?
>
> If so, try to follow the rubygame install instructions once again.
>
> https://github.com/rubygame/rubygame/wiki/Mac-Install-Guide
>
> Your error messages point that it can't find the rubygame gem.
>
> If the problem occurs with other gems, make sure you have installed
> them before "requiring" them.
> Most simple gems installs with
>
> $ gem install <gem_name>
>
> Tell us if any progress.
>
> Best regards,
> Abinoam Jr.
>
>
> On Thu, Feb 6, 2014 at 12:48 AM, Raf Ri <lists / ruby-forum.com> wrote:
>> localhost:~ user$ uname -a
>> Darwin localhost 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun  7
>> 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386
>>
>>
>> which ruby
>> /Users/user/.rvm/rubies/ruby-2.1.0/bin/ruby
>>
>> which gem
>> /Users/user/.rvm/rubies/ruby-2.1.0/bin/gem
>>
>> rvm list
>>
>> rvm rubies
>>
>>    jruby-1.7.10 [ x86_64 ]
>>    ruby-1.9.2-p320 [ x86_64 ]
>>    ruby-2.0.0-p247 [ x86_64 ]
>>    ruby-2.0.0-p353 [ x86_64 ]
>> =3D* ruby-2.1.0 [ x86_64 ]
>>
>> # =3D> - current
>> # =3D* - current && default
>> #  * - default
>>
>> env|grep -i ruby
>> GEM_HOME=3D/Users/user/.rvm/gems/ruby-2.1.0
>> IRBRC=3D/Users/user/.rvm/rubies/ruby-2.1.0/.irbrc
>> MY_RUBY_HOME=3D/Users/user/.rvm/rubies/ruby-2.1.0
>> PATH=3D/Users/user/.rvm/gems/ruby-2.1.0/bin:/Users/user/.rvm/gems/ruby-2=
.1.0@global/bin:/Users/user/.rvm/rubies/ruby-2.1.0/bin:/opt/local/bin:/opt/=
local/sbin:/Library/Frameworks/Python.framework/Versions/3.2/bin:/Library/F=
rameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/=
usr/local/bin:/opt/X11/bin:/usr/local/git/bin:/usr/X11/bin:/Users/user/.rvm=
/bin
>> GEM_PATH=3D/Users/user/.rvm/gems/ruby-2.1.0:/Users/user/.rvm/gems/ruby-2=
.1.0@global
>> ------------------------------------------------------------------------=
--
>> As far as a line of code, I won't even use one of my own. I'll call a
>> gem that I've been trying to test on my machine to show you. It should
>> be attached as a .rb file.
>>
>> My error return in Aptana for running from the interface is as follows:
>>
>> /Users/user/.rvm/rubies/ruby-2.1.0/lib/ruby/site_ruby/2.1.0/rubygems/cor=
e_ext/kernel_require.rb:55:in
>> `require': cannot load such file -- rubygame (LoadError)
>>   from
>> /Users/user/.rvm/rubies/ruby-2.1.0/lib/ruby/site_ruby/2.1.0/rubygems/cor=
e_ext/kernel_require.rb:55:in
>> `require'
>>   from /Users/user/Documents/Aptana Studio 3
>> Workspace/PacAttack/PacAttack
>> Ruby\/gameprog1/gameprog1/01_main_loop.rb:3:in `<main>'
>>
>>
>> I'm absolutely certain that whatever this issue is will end up being
>> user error on my behalf- I just hope that you could help me figure it
>> out. Thanks a ton man.
>>
>> --
>> Posted via http://www.ruby-forum.com/.