On Jan 10, 2014, at 13:35, Ryan Davis <ryand-ruby / zenspider.com> wrote:

>=20
> On Jan 8, 2014, at 16:19, Eric Peterson <epeterson / rhapsody.com> =
wrote:
>=20
> In your debugging output it says:
>=20
>>   - x86_64-darwin-11
>=20
> but here you're trying to install:
>=20
>>   no such name =
(http://api.rubygems.org/quick/Marshal.4.8/ffi-1.0.4-x86-mingw32.gemspec.r=
z)
>=20
> which, in and of itself, doesn't make sense. But if you look at what's =
available (gem list -d -r ffi):
>=20
> ffi (1.9.3, 0.6.3)
>   Platforms:
>       0.6.3: x86-mswin32
>       1.9.3: java, ruby, x64-mingw32, x86-mingw32
>   Author: Wayne Meissner
>   Homepage: http://wiki.github.com/ffi/ffi
>=20
>   Ruby FFI
>=20
> The latest version for mingw32 is 1.9.3, so I'm guessing you're trying =
to install something (directly or indirectly) that is very old and/or =
unmaintained.

FWIW, this installs fine for me:

10004 % gem i -i xxx !$
gem i -i xxx sys-filesystem
Fetching: ffi-1.9.3.gem (100%)
Building native extensions.  This could take a while...
Successfully installed ffi-1.9.3
Fetching: sys-filesystem-1.1.1.gem (100%)
Successfully installed sys-filesystem-1.1.1
Parsing documentation for ffi-1.9.3
Installing ri documentation for ffi-1.9.3
Parsing documentation for sys-filesystem-1.1.1
Installing ri documentation for sys-filesystem-1.1.1
Done installing documentation for ffi, sys-filesystem after 135 seconds
2 gems installed