> > Question: Since many developers out there in Ruby-land are using 1.7.x
> > of Ruby, would it be possible to have binary builds of 1.7 mswin32 and
> > 1.7 Linux in addition to the 1.6 versions?  It just makes it easier to
> > not have to download and build Fox, FXRuby, etc.
>
> OK, I just uploaded a Windows installer for Ruby 1.7 (CVS
> version) as well:
>
>
> http://prdownloads.sourceforge.net/fxruby/FXRuby-1.0.10-win32-ruby17.exe
>
> I can probably do the same for Linux but it will need to wait until
> tomorrow.
>
> Hope this helps,
>
> Lyle


Was a Linux binary for Ruby 1.7 made available? I'm trying to install from
source, and get this error when running install.rb setup:

install.rb: entering setup phase...
---> lib
---> lib/fox
<--- lib/fox
<--- lib
---> ext
---> ext/fox
make
install.rb:397: warning: Unsecure world writeable dir
/usr/local/development , mode 040777
g++ -fPIC -g -O2 -O0 -Iinclude -I. -I/usr/local/lib/ruby/1.7/i586-linux -I/
usr/local/development/ruby-mods/FXRuby-1.0.10/ext/fox -DHAVE_SYS_TIME_H -DH
AVE_SIGNAL_H   -I/usr/local/include -I/usr/local/include/fox -c
core_wrap.cpp
In file included from /usr/include/math.h:63,
                 from /usr/local/include/fox/fx.h:31,
                 from include/FXRbCommon.h:55,
                 from core_wrap.cpp:384:
/usr/include/bits/mathcalls.h:86: declaration of `double acosh (double)
throw ()' throws different exceptions
/usr/local/lib/ruby/1.7/i586-linux/missing.h:15: than previous declaration
`double acosh (double)'
/usr/include/bits/mathcalls.h:88: declaration of `double asinh (double)
throw ()' throws different exceptions
/usr/local/lib/ruby/1.7/i586-linux/missing.h:16: than previous declaration
`double asinh (double)'
/usr/include/bits/mathcalls.h:90: declaration of `double atanh (double)
throw ()' throws different exceptions
/usr/local/lib/ruby/1.7/i586-linux/missing.h:17: than previous declaration
`double atanh (double)'
/usr/include/bits/mathcalls.h:150: declaration of `double hypot
(double, double) throw ()' throws different exceptions
/usr/local/lib/ruby/1.7/i586-linux/missing.h:43: than previous declaration
`double hypot (double,
double)'
make: *** [core_wrap.o] Error 1
setup failed
'system make' failed
try 'ruby install.rb --help' for usage


I'm using ruby 1.7.2 (2002-05-16) [i586-linux] on Mandrake 8.2, with
fox-1.0.11 installed from source.
Is there a way around this error?

Thanks,


James