> This isn't necessarily the problem, but if you have fox 1.0.7 and 
> FXRuby 1.0.10 it sounds like they might not be compatible versions.
> 
> Can you upgrade your fox to 1.0.10 as well?

As of the 1.0.x releases the FOX 1.0 API is frozen and so it's no longer 
necessary for the FXRuby and FOX versions to match exactly. Any FXRuby 
1.0.x should be compatible with any FOX 1.0.x. The only reason to 
upgrade either would be to obtain bug fixes for either component.

Jeroen has begun work on FOX 1.1 development (see 
http://www.fox-toolkit.org/news.html) and sometime soon I'll pick that 
up for FXRuby as well. For that branch (as was the case for the pre-1.0 
releases) there will most likely be a tight link between the FOX and 
FXRuby versions; e.g. FXRuby 1.1.10 would only be compatible with FOX 
1.1.10.