$ irb -w
irb(main):001:0> require "complex"
lib/complex.rb is deprecated
=> true


"complex" and "rational" are already in core in newer versions

-- 
Posted via http://www.ruby-forum.com/.