As your error code said you need to install SQLite3 from
http://www.sqlite.org/ ... In addition to the gem theres the need of a
engine...
El 02/08/2013 12:59, "cristian cristian" <lists / ruby-forum.com> escribi=F3:

> Grrr...still I got a problem.... 'failed to build gem native
> extension'...
> ... :(
>
>
>
> C:\Ruby200\devkit>gem install sqlite3 --platform=3Druby --
> --with-sqlite3-include=3D
> c:/knapsack/sqlite/include --with-sqlite3-lib=3Dc:/knapsack/sqlite/lib
> --with-sqli
> te3-dir=3Dc:/knapsack/sqlite/bin
> Temporarily enhancing PATH to include DevKit...
> Building native extensions with:
> '--with-sqlite3-include=3Dc:/knapsack/sqlite/incl
> ude --with-sqlite3-lib=3Dc:/knapsack/sqlite/lib
> --with-sqlite3-dir=3Dc:/knapsack/sql
> ite/bin'
> This could take a while...
> ERROR:  Error installing sqlite3:
>         ERROR: Failed to build gem native extension.
>
>     C:/Ruby200/bin/ruby.exe extconf.rb
> --with-sqlite3-include=3Dc:/knapsack/sqlite
> /include --with-sqlite3-lib=3Dc:/knapsack/sqlite/lib
> --with-sqlite3-dir=3Dc:/knapsac
> k/sqlite/bin
> checking for sqlite3.h... yes
> checking for sqlite3_libversion_number() in -lsqlite3... no
> sqlite3 is missing. Install SQLite3 from http://www.sqlite.org/ first.
> *** extconf.rb failed ***
> Could not create Makefile due to some reason, probably lack of necessary
> libraries and/or headers.  Check the mkmf.log file for more details.
> You may
> need configuration options.
>
> Provided configuration options:
>         --with-opt-dir
>         --without-opt-dir
>         --with-opt-include
>         --without-opt-include=3D${opt-dir}/include
>         --with-opt-lib
>         --without-opt-lib=3D${opt-dir}/lib
>         --with-make-prog
>         --without-make-prog
>         --srcdir=3D.
>         --curdir
>         --ruby=3DC:/Ruby200/bin/ruby
>         --with-sqlite3-dir
>         --with-sqlite3-include=3D${sqlite3-dir}/include
>         --with-sqlite3-lib=3D${sqlite3-dir}/
>         --enable-local
>         --disable-local
>         --with-sqlite3lib
>         --without-sqlite3lib
>
>
> Gem files will remain installed in
> C:/Ruby200/lib/ruby/gems/2.0.0/gems/sqlite3-1
> .3.7 for inspection.
> Results logged to
> C:/Ruby200/lib/ruby/gems/2.0.0/gems/sqlite3-1.3.7/ext/sqlite3/
> gem_make.out
>
> --
> Posted via http://www.ruby-forum.com/.
>
>