Thank you for the suggestion Joel. I followed Scotts instructions and 
yet theres a problem. Why does this work fine when I use datamapper?

Here's the error message when I follow Scotts instructions.

C:\knapsack>gem install sqlite3 --platform=ruby 
--with-opt-dir=C:/Knapsack
ERROR:  While executing gem ... (OptionParser::InvalidOption)
    invalid option: --with-opt-dir=C:/Knapsack



Br
cristian

-- 
Posted via http://www.ruby-forum.com/.