Hi,

In message "Re: what's the calling method name?"
    on 02/05/22, nobu.nokada / softhome.net <nobu.nokada / softhome.net> writes:

|Meanwhile, I vote for "class", "type" and "hash".

For __name__, the "name" should be a name of a universal method often
conflicts with others.  "__send__" and "__id__" satisfies this
condition.

"class", "type", "hash" and probably "method_missing" may satisfy this
first condition too.  But there're some other conditions.

For "class",  it's a reserved word, and its meaning is very clear.
Maybe there's no conflict.

For "type", this is a bad method name, because it returns the
receiver's class.  It was there for historical reason (reserved words
could not be used for method names before).  It's not worth to be
preserved by "__type__".

For "hash" is a callback.  If we add "__hash__", Hash objects would
use this, and this will bring us imcompatibility.  Probably same for
"method_missing".

In conclusion, I don't feel the need for these __name__ methods (yet).

							matz.