Hello everyone,

This is my first post, and decided to learn something new (ruby). So
Hello Everyone  and apologizes in advance if this is not the correct
place to ask Pry questions.

but i got the following error, and not really sure what could be
happening

$ pry
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:11: warning: already
initialized constant DEFAULT_HOOKS
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:17: warning: already
initialized constant DEFAULT_PRINT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:55: warning: already
initialized constant SIMPLE_PRINT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:64: warning: already
initialized constant CLIPPED_PRINT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:69: warning: already
initialized constant DEFAULT_EXCEPTION_HANDLER
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:78: warning: already
initialized constant DEFAULT_PROMPT_NAME
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:81: warning: already
initialized constant DEFAULT_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:92: warning: already
initialized constant SIMPLE_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:94: warning: already
initialized constant SHELL_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:101: warning: already
initialized constant NAV_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:116: warning: already
initialized constant DEFAULT_CONTROL_D_HANDLER
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:132: warning: already
initialized constant DEFAULT_SYSTEM
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:140: warning: already
initialized constant INITIAL_PWD
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:185: warning: already
initialized constant DEFAULT_EXCEPTION_WHITELIST
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry/cli.rb:7: warning: already
initialized constant NoOptionsError
Found plugin pry-de, but could not require 'pry-de'
cannot load such file -- pry-de
Found plugin pry-docmore, but could not require 'pry-docmore'
can't activate pry-0.9.11, already activated pry-0.9.12.2
Found plugin pry-fkeys, but could not require 'pry-fkeys'
cannot load such file -- pry-fkeys
Found plugin pry-full, but could not require 'pry-full'
cannot load such file -- pry-full
Found plugin pry-plus, but could not require 'pry-plus'
cannot load such file -- pry-plus
[1] pry(main)> #
[2] pry(main)>
[3] pry(main)> RUBY_VERSION
"1.9.3"
[8] pry(main)>
[~]
$ pry -v
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:11: warning: already
initialized constant DEFAULT_HOOKS
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:17: warning: already
initialized constant DEFAULT_PRINT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:55: warning: already
initialized constant SIMPLE_PRINT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:64: warning: already
initialized constant CLIPPED_PRINT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:69: warning: already
initialized constant DEFAULT_EXCEPTION_HANDLER
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:78: warning: already
initialized constant DEFAULT_PROMPT_NAME
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:81: warning: already
initialized constant DEFAULT_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:92: warning: already
initialized constant SIMPLE_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:94: warning: already
initialized constant SHELL_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:101: warning: already
initialized constant NAV_PROMPT
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:116: warning: already
initialized constant DEFAULT_CONTROL_D_HANDLER
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:132: warning: already
initialized constant DEFAULT_SYSTEM
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:140: warning: already
initialized constant INITIAL_PWD
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry.rb:185: warning: already
initialized constant DEFAULT_EXCEPTION_WHITELIST
/var/lib/gems/1.9.1/gems/pry-0.9.12.2/lib/pry/cli.rb:7: warning: already
initialized constant NoOptionsError
Pry version 0.9.12.2 on Ruby 1.9.3
[~]

This are the gems that i have installed on my PC

$ gem list

*** LOCAL GEMS ***

actionmailer (4.0.0)
actionpack (4.0.0)
activemodel (4.0.0)
activerecord (4.0.0)
activerecord-deprecated_finders (1.0.3)
activesupport (4.0.0)
alias (0.2.3)
ansi (1.4.3)
arel (4.0.0)
atomic (1.1.10)
awesome_print (1.1.0)
beg (0.0.3)
binding_of_caller (0.7.2, 0.6.8)
bond (0.4.3)
boson (1.2.4)
boson-more (0.2.2)
builder (3.1.4)
bundler (1.3.5)
childprocess (0.3.9, 0.3.6)
clipboard (1.0.5)
coderay (1.0.9, 1.0.8)
columnize (0.3.6)
debug_inspector (0.0.2)
debugger (1.6.1, 1.2.3)
debugger-linecache (1.2.0, 1.1.2)
debugger-ruby_core_source (1.2.3, 1.1.6)
diff-lcs (1.2.4, 1.1.3)
diffy (3.0.1, 2.1.3)
erubis (2.7.0)
every_day_irb (1.5.0)
fancy_irb (0.7.3)
ffi (1.9.0, 1.2.0)
formatador (0.2.4)
g (1.7.2)
grit (2.5.0)
guard (1.8.1, 1.6.1)
guard-bundler (1.0.0)
guard-spork (1.5.1, 1.4.0)
guard-sporkminitest (0.0.2)
hike (1.2.3)
hirb (0.7.1)
i18n (0.6.4)
interactive_editor (0.0.10)
interception (0.3)
irbtools (1.5.0)
jist (1.5.1, 1.4.0)
json (1.8.0, 1.7.6)
listen (1.2.2, 0.7.1)
lumberjack (1.0.4, 1.0.2)
mail (2.5.4)
method_locator (0.0.4)
method_source (0.8.1)
methodfinder (1.2.5)
mime-types (1.23, 1.19)
mini_portile (0.5.1)
minitest (5.0.6, 4.7.5, 4.3.3)
multi_json (1.7.7)
nokogiri (1.6.0, 1.5.6)
ori (0.1.0)
paint (0.8.6)
polyglot (0.3.3)
posix-spawn (0.3.6)
pry (0.9.12.2, 0.9.11)
pry-awesome_print (9.6.5)
pry-de (0.2.0, 0.1.0)
pry-debugger (0.2.2, 0.2.1)
pry-developer_tools (0.1.1)
pry-doc (0.4.6, 0.4.4)
pry-docmore (0.1.1)
pry-editline (1.1.2, 1.1.1)
pry-exception_explorer (0.2.3)
pry-fkeys (0.2.3)
pry-full (2.1.0, 1.2.0)
pry-git (0.2.3)
pry-highlight (0.0.1)
pry-plus (1.0.0, 0.2.0)
pry-pretty-numeric (0.1.1)
pry-rescue (1.1.1, 0.15)
pry-stack_explorer (0.4.9, 0.4.7)
pry-syntax-hacks (0.0.6)
pry-theme (0.2.0, 0.1.3)
rack (1.5.2)
rack-test (0.6.2)
rails (4.0.0)
railties (4.0.0)
rake (10.1.0, 10.0.3)
rb-fsevent (0.9.3)
rb-inotify (0.9.0, 0.8.8)
rb-kqueue (0.2.0)
rspec (2.14.1)
rspec-core (2.14.4)
rspec-expectations (2.14.0)
rspec-mocks (2.14.1)
slop (3.4.5, 3.3.3)
spoon (0.0.4)
spork (0.9.2)
spork-minitest (0.0.3)
sprockets (2.10.0)
sprockets-rails (2.0.0)
thor (0.18.1, 0.16.0)
thread_safe (0.1.0)
tilt (1.4.1)
treetop (1.4.14)
turn (0.9.6)
tzinfo (0.3.37)
unicode-display_width (0.1.1)
wirb (1.0.1)
wirble (0.1.3)
working (1.0.1, 0.0.8)
yard (0.8.6.2, 0.8.3)
zucker (13.1)

would someone please help on what i am missing here?

thank you
Gosse!

-- 
Posted via http://www.ruby-forum.com/.