I'm using RPG Maker VX Ace to make RPG games. It has script database
which using Ruby 1.9.2 version(named RGSS3). I wanna use Net::Http class
so I can connect my mysql database with Http.Get function(PHP). RGSS3
doesn't include Net::Http library so I thought that I should call it
with additional. I copy/pasted 'net' folder to 'myfolder' in Ruby 1.9.2
libraries and I used this :


load 'myfolder/net/http.rb'


When I run it, It makes error like :

no such file loaded -- socket.so

I don't know how can I get this file. I used search engine and I
couldn't get anything like this. May it any compile-version?

Do you have any suggestions about it or any alternative ways to use
Net::Http class on rgss3?

-- 
Posted via http://www.ruby-forum.com/.