Am 06.07.2013 02:04, schrieb jab jabono:
> Hi all !
>
> First, I'm a big newbie on ruby and that stuff so maybe my question is
> really cloddish. So, I'm trying to install do_squlite3 with the command
> " gem install do_sqlite3 -v '0.10.13'" it doesn't work and I don't know
> how to fix it.
[...]
> Building native extensions.  This could take a while...
> ERROR:  Error installing do_sqlite3:
>    ERROR: Failed to build gem native extension.
>
>      /usr/local/rvm/rubies/ruby-2.0.0-p247/bin/ruby extconf.rb
> checking for sqlite3.h... no
> *** extconf.rb failed ***
> Could not create Makefile due to some reason, probably lack of necessary
> libraries and/or headers.  Check the mkmf.log file for more details.

Is sqlite installed on your system?
You should also need an sqlite dev / devel package to be able
to build the native extensions, maybe called 'sqlite-devel'.
I'm not sure, though, since I'm not using Fedora myself.

Hope this helps,
Marcus


-- 
<https://github.com/stomar/>