I use ruby in cloudfoundry.but recently got a error in a
flie(plugin.rb):
"in `require': no such file to load -- rest_client (LoadError)"

I use "gem" in Ubuntu. "gem list" shows I really have rest-client1.6.7.

"ruby -v": ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]

in the folder: have 2 version ruby(installed by cloud foundry,not me) :
"ruby-1.9.2-p180/lib/ruby/gems/1.9.1"
"ruby-1.8.7-p357/lib/ruby/gems/1.8".

They both have "rest-client-1.6.7" under their folder.

I do not have "Gemfile" in this,because "plugin.rb" is called by
cloudfoundry itself. And I make a test.rb in the same folder,run it
myself and it works fine,no error with"require 'rest_client' "
maybe cloudfoundry use 1.9.2 itself?

I'm confused about ruby file structure, how to solve that problem?

thanks for help.

-- 
Posted via http://www.ruby-forum.com/.