Ben Daniels <lists / ruby-forum.com> wrote:
> I am trying to install Ruby 2.0.0 from source on Red Hat 6.
> 
> Based on some dependencies and configuration, RVM wasn't working, which
> is what I normally use.
> 
> So I downloaded the .tgz and did a ./configure, make, make install.  Now
> when I try to run irb, it throws this error.
> 
> 
> #########
> 
> /usr/local/lib/ruby/site_ruby/2.0.0/rbconfig/datadir.rb:9:in `<top
> (required)>': Use RbConfig instead of obsolete and deprecated Config.
> /usr/local/lib/ruby/site_ruby/2.0.0/rbconfig/datadir.rb:12:in
> `respond_to?': Use RbConfig instead of obsolete and deprecated Config.
> /usr/local/lib/ruby/2.0.0/irb/locale.rb:150:in `block in search_file':
> undefined method `try_activate' for Gem:Module (NoMethodError)
>   from /usr/local/lib/ruby/2.0.0/irb/locale.rb:158:in `block in
> each_localized_path'
>   from /usr/local/lib/ruby/2.0.0/irb/locale.rb:167:in `each_sublocale'
>   from /usr/local/lib/ruby/2.0.0/irb/locale.rb:157:in
> `each_localized_path'
>   from /usr/local/lib/ruby/2.0.0/irb/locale.rb:145:in `search_file'
>   from /usr/local/lib/ruby/2.0.0/irb/locale.rb:124:in `find'
>   from /usr/local/lib/ruby/2.0.0/irb/locale.rb:108:in `load'
>   from /usr/local/lib/ruby/2.0.0/irb/locale.rb:32:in `initialize'
>   from /usr/local/lib/ruby/2.0.0/irb/init.rb:114:in `new'
>   from /usr/local/lib/ruby/2.0.0/irb/init.rb:114:in `init_config'
>   from /usr/local/lib/ruby/2.0.0/irb/init.rb:16:in `setup'
>   from /usr/local/lib/ruby/2.0.0/irb.rb:380:in `start'
>   from /usr/local/bin/irb:12:in `<main>'
> 
> #########
> 
> Has anyone seen this?  Is it as simple as having to make an adjustment
> in my setup.rb file?  Not sure which one I have to adjust.
> 
> New to this, so any help would be greatly appreciated.

Hmm, I just ran a source install and did not run into this, although it
was a deb6 based system, not rhel. Did you pay attention to all the
config and make failures, if any? I noticed the make proceeded even with
some things I thought were rather necessary. I can't speak specifically
to what's happening here, but take a look at my capture of my install:

http://wiki.tamaratemple.com/Technology/BuildRubySystemFromSource

mainly the packages needed.