I have been trying to install Ruby on Rails and get an environment
working for about 10 hours now.

I inherited a project from an employee who left; a projected checked out
from SCCM but no instructions on how to setup Ruby on Rails or what to
deploy etc so started googling around.

I found so many articles about the right way and the wrong way and some
were adamant that I listen to no one else, and after following those
instructions things still failed.

I think I have worked out most problems.

---
$ruby -v
 reveals

ruby 1.9.2p320 (2012-04-20 revision 35421) [x86_64-linux]

When I attempt to hit an URL:  http://localhost:8080/rcgi/Some.rb

I get in the output that a module 'money' is needed.

so I run
  $sudo gem install money

this is the output I receive:

---
Successfully installed dbd-sqlite3-1.2.5
1 gem installed
Installing ri documentation for dbd-sqlite3-1.2.5...
Installing RDoc documentation for dbd-sqlite3-1.2.5...
ERROR:  Error installing money:
  money requires Ruby version >= 1.9.2.

---
WTF?


I just did a $ruby -v and saw that I had Ruby 1.9.2 installed.
Also why do I get these first two lines (everytime I run this gem
install money command?:

   wtf>Successfully installed dbd-sqlite3-1.2.5
   wtf>1 gem installed
   wtf>Installing ri documentation for dbd-sqlite3-1.2.5...
   wtf>Installing RDoc documentation for dbd-sqlite3-1.2.5...

If I run $sudo gem install money, I get those lines again.  WTF?

---
How do I get 'money' installed?  Why doesn't money work with 1.9.3 or
1.8.7 for that matter?

---
sincerely,


J.V.

-- 
Posted via http://www.ruby-forum.com/.