OK, here is what seems to be the issue.

There are currently two builds for 2.0.0-p195, listed below:

Ruby 2.0.0-p195
Ruby 2.0.0-p195 (x64)

and three different DevKits:

DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe
DevKit-mingw64-32-4.7.2-20130224-1151-sfx.exe
DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exe

I have Window 7 Home Premium 64-bit on an Intel I5 64-bit cpu.

I have installed both versions for 2.0.0-p195, and both are built only
for 32-bits.  However, the DevKits are built for both 32-bits build for
64-bits cpsu (mingw64-32) and 64-bit builds for 64-bit cpus
(mingw64-64).

What seems to be missing is a full mingw64-64 build of 2.0.0-p195 itself
for it to utilize the full 64-bit registers for 64-bit cpus, as is the
case for native builds with Linux on 64-bit cpus.

If Ruby 2.0.0-p195 (x64) is still just a 32-bit build for 64-bit cpus
how can DevKit-mingw64-64 be used to build 64-bit gems when there is no
full mingw64-64 build available for Ruby?

-- 
Posted via http://www.ruby-forum.com/.