Thanks Jeremy for the quick response! I was not aware of this. My
problem has
been fixed! I am using a book that was written using ruby 1.7.0. but I
am using Ruby 2.0.0p195 version. Do you know of any resource that can 
provide
me with methods that have changed in the newer versions? This will help
me a lot. If such a resource is not available I will just google when i 
encounter errors.
thanks alot!!

nyaks

-- 
Posted via http://www.ruby-forum.com/.