You can run side-by-side installs. I think I've heard RVM mentioned in 
relation to that.

If I ever get time I'm going to migrate onto Ruby 2.0, so you might want 
to look into doing that directly rather than going via 1.9.3 first.

As far as I know Ruby versions are mostly backward compatible regarding 
code, apart from the odd hiccup like the behaviour of Hash#select / 
Enumerable#select. Operating with multiple versions for a while seems 
the best way to manage the upgrade and give time to smooth out any 
inconsistency.

-- 
Posted via http://www.ruby-forum.com/.