if you did rvm get head, it should install ruby 2.0 by default... :)

Julian

On 31/03/2013, at 9:20 PM, 7stud -- <lists / ruby-forum.com> wrote:

> Thanks for the response Jullian.  Now there seems to be a ruby gems=20
> problem:
>=20
> =3D=3D=3D
> Error running 'env=20
> =
GEM_PATH=3D/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/rub=
y-2.0.0-p0@global:/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/g=
ems/ruby-2.0.0-p0@global=20
> GEM_HOME=3D/Users/7stud/.rvm/gems/ruby-2.0.0-p0=20
> /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby -d=20
> /Users/7stud/.rvm/src/rubygems-2.0.3/setup.rb --verbose',
> please read /Users/7stud/.rvm/log/ruby-2.0.0-p0/rubygems.install.log
> Installation of rubygems did not complete successfully.
> Saving wrappers to '/Users/7stud/.rvm/wrappers/ruby-2.0.0-p0'........
>=20
> ruby-2.0.0-p0 - #adjusting #shebangs for (gem irb erb ri rdoc testrb=20=

> rake).
> ruby-2.0.0-p0 - #importing default gemsets, this may take=20
> time.......................
> Install of ruby-2.0.0-p0 - #complete
>=20
> =3D=3D=3D
>=20
>=20
> Here is what I did:
>=20
> ~/perl_programs$ rvm update
> ERROR: rvm update has been removed. See 'rvm get' and rvm 'rubygems' =
CLI=20
> API instead
>=20
>=20
> ~/perl_programs$ rvm get stable
>  % Total    % Received % Xferd  Average Speed   Time    Time     Time=20=

> Current
>                                 Dload  Upload   Total   Spent    Left=20=

> Speed
> 100 13130  100 13130    0     0   5665      0  0:00:02  0:00:02 =
--:--:--=20
> 55872
> Downloading RVM from wayneeseguin branch stable
> bash: line 110: rvm_is_a_shell_function: command not found
>  % Total    % Received % Xferd  Average Speed   Time    Time     Time=20=

> Current
>                                 Dload  Upload   Total   Spent    Left=20=

> Speed
> 100 3261k  100 3261k    0     0   229k      0  0:00:14  0:00:14 =
--:--:--=20
> 215k
>=20
> Upgrading the RVM installation in /Users/7stud/.rvm/
>    RVM PATH line found in /Users/7stud/.bashrc /Users/7stud/.zshrc.
>    RVM sourcing line found in /Users/7stud/.bash_profile=20
> /Users/7stud/.zlogin.
>=20
> Upgrade Notes:
>=20
>  * If you wish to get more default(global) gems installed, install RVM=20=

> with this flag: --with-gems=3D"pry vagrant"
>    this option is remembered, it's enough to use it once.
>=20
>  * Binary rubies are installed by default if available, you can read=20=

> about it in help:
>      rvm help install
>      rvm help mount
>=20
>  * The default umask for multi-user installation got extended to =
`umask=20
> u=3Drwx,g=3Drwx,o=3Drx`,
>    comment it out to avoid automatic updates.
>=20
>  * If you encounter any issues with a ruby 'X' your best bet is to:
>      rvm get head && rvm reinstall X --debug
>=20
>  * RVM will run 'rvm requirements' by default, to disable run:
>      echo rvm_autolibs_flag=3D0 >> ~/.rvmrc
>=20
>  * RVM will set first installed ruby as default and use it if run as=20=

> function.
>    To avoid this behavior either use full path to rvm binary or prefix=20=

> it with `command `.
>=20
>  * To update RVM loading code run 'rvm get ... --auto-dotfiles'
>=20
>  * RVM will try automatically use available package manager, might=20
> require `sudo`,
>    read more about it in `rvm help autolibs`
>=20
>=20
> # RVM:  Shell scripts enabling management of multiple ruby =
environments.
> # RTFM: https://rvm.io/
> # HELP: http://webchat.freenode.net/?channels=3Drvm (#rvm on=20
> irc.freenode.net)
> # Cheatsheet: http://cheat.errtheblog.com/s/rvm
> # Screencast: http://screencasts.org/episodes/how-to-use-rvm
>=20
> # In case of any issues run 'rvm requirements' or read 'rvm notes'
>=20
> Upgrade of RVM in /Users/7stud/.rvm/ is complete.
>=20
> # 7stud,
> #
> #   Thank you for using RVM!
> #   I sincerely hope that RVM helps to make your life easier and
> #   more enjoyable!!!
> #
> # ~Wayne
>=20
> RVM reloaded!
>=20
>=20
>=20
>=20
> ~/perl_programs$ rvm install ruby-2.0.0-p0
> Searching for binary rubies, this might take some time.
> No binary rubies available for: osx/10.6/i386/ruby-2.0.0-p0.
> Continuing with compilation. Please read 'rvm mount' to get more=20
> information on binary rubies.
> Installing requirements for osx, might require sudo password.
> -bash: requirements_find_smf: command not found
> Requested installation with homebrew libs, but homebrew is not=20
> available.
> RVM autolibs is now configured with mode '2' =3D> 'check and stop if=20=

> missing',
> please run `rvm autolibs enable` to let RVM do it's job or run and =
read=20
> `rvm autolibs [help]`
> or visit https://rvm.io/rvm/autolibs for more information.
>=20
>=20
>=20
> ~/perl_programs$ rvm autolibs enable
> ~/perl_programs$ rvm install ruby-2.0.0-p0
> Searching for binary rubies, this might take some time.
> No binary rubies available for: osx/10.6/i386/ruby-2.0.0-p0.
> Continuing with compilation. Please read 'rvm mount' to get more=20
> information on binary rubies.
> Installing requirements for osx, might require sudo password.
> -bash: requirements_find_smf: command not found
> Installing homebrew.
> Initialized empty Git repository in /Users/7stud/.homebrew/.git/
> remote: Counting objects: 107033, done.
> remote: Compressing objects: 100% (44564/44564), done.
> remote: Total 107033 (delta 75989), reused 89713 (delta 61542)
> Receiving objects: 100% (107033/107033), 16.11 MiB | 229 KiB/s, done.
> Resolving deltas: 100% (75989/75989), done.
> =46rom https://github.com/mxcl/homebrew
> * [new branch]      gh-pages   -> origin/gh-pages
> * [new branch]      go         -> origin/go
> * [new branch]      master     -> origin/master
> * [new branch]      superwip   -> origin/superwip
> HEAD is now at 04e7b94 sqlite 3.7.16.1
> Already up-to-date.
> Installing required packages: autoconf, automake, libtool, pkg-config,=20=

> libyaml, readline, libxml2, libxslt, libksba, openssl,=20
> =
sqlite....................................................................=
..........................................................................=
...................................
> Updating certificates in '/Users/7stud/.rvm/etc/openssl/cert.pem'.
> Doing /Users/7stud/.rvm/etc/openssl
> cert.pem =3D> 33f86c5a.0
> Installing Ruby from source to: =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0,=20
> this may take a while depending on your cpu(s)...
> ruby-2.0.0-p0 - #downloading ruby-2.0.0-p0, this may take a while=20
> depending on your connection...
> =
########################################################################=20=

> 100.0%
> ruby-2.0.0-p0 - #extracting ruby-2.0.0-p0 to=20
> /Users/7stud/.rvm/src/ruby-2.0.0-p0
> ruby-2.0.0-p0 - #extracted to /Users/7stud/.rvm/src/ruby-2.0.0-p0
> ruby-2.0.0-p0 -=20
> =
#configuring..............................................................=
..........................................................................=
..........................................................................=
..........................................................................=
..........................................................................=
..........................................................................=
.....................................................................
> ruby-2.0.0-p0 -=20
> =
#compiling................................................................=
..........................................................................=
..........................................................................=
..........................................................................=
..........................................................................=
..........................................................................=
..........................................................................=
.........................................................................
> ruby-2.0.0-p0 - #installing=20
> =
..........................................................................=
........................................................
> Retrieving rubygems-2.0.3
> =
########################################################################=20=

> 100.0%
> Extracting rubygems-2.0.3 ...
> Removing old Rubygems files...
> Installing rubygems-2.0.3 for=20
> =
ruby-2.0.0-p0.............................................................=
.................................................................
> Error running 'env=20
> =
GEM_PATH=3D/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/rub=
y-2.0.0-p0@global:/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/g=
ems/ruby-2.0.0-p0@global=20
> GEM_HOME=3D/Users/7stud/.rvm/gems/ruby-2.0.0-p0=20
> /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby -d=20
> /Users/7stud/.rvm/src/rubygems-2.0.3/setup.rb --verbose',
> please read /Users/7stud/.rvm/log/ruby-2.0.0-p0/rubygems.install.log
> Installation of rubygems did not complete successfully.
> Saving wrappers to '/Users/7stud/.rvm/wrappers/ruby-2.0.0-p0'........
>=20
> ruby-2.0.0-p0 - #adjusting #shebangs for (gem irb erb ri rdoc testrb=20=

> rake).
> ruby-2.0.0-p0 - #importing default gemsets, this may take=20
> time.......................
> Install of ruby-2.0.0-p0 - #complete
> ~/perl_programs$
>=20
>=20
>=20
> Here's the log file that the error message said to read:
>=20
>=20
>=20
> [2013-03-31 00:52:28] /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby
> current path: /Users/7stud/.rvm/src/rubygems-2.0.3
> command(7): env=20
> =
GEM_PATH=3D/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/gems/rub=
y-2.0.0-p0@global:/Users/7stud/.rvm/gems/ruby-2.0.0-p0:/Users/7stud/.rvm/g=
ems/ruby-2.0.0-p0@global=20
> GEM_HOME=3D/Users/7stud/.rvm/gems/ruby-2.0.0-p0=20
> /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/ruby -d=20
> /Users/7stud/.rvm/src/rubygems-2.0.3/setup.rb --verbose
> Exception `LoadError' at=20
> /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/rubygems.rb:1073 =
-=20
> cannot load such file -- rubygems/defaults/operating_system
> Exception `LoadError' at=20
> /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/rubygems.rb:1082 =
-=20
> cannot load such file -- rubygems/defaults/ruby
> mkdir -p =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0
> mkdir -p /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin
> install -c -m 0644 gauntlet_rubygems.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/gauntlet_r=
ubygems.rb
> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems
> install -c -m 0644 rubygems/available_set.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/a=
vailable_set.rb
> install -c -m 0644 rubygems/command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommand.rb
> install -c -m 0644 rubygems/command_manager.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommand_manager.rb
> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands
> install -c -m 0644 rubygems/commands/build_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/build_command.rb
> install -c -m 0644 rubygems/commands/cert_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/cert_command.rb
> install -c -m 0644 rubygems/commands/check_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/check_command.rb
> install -c -m 0644 rubygems/commands/cleanup_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/cleanup_command.rb
> install -c -m 0644 rubygems/commands/contents_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/contents_command.rb
> install -c -m 0644 rubygems/commands/dependency_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/dependency_command.rb
> install -c -m 0644 rubygems/commands/environment_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/environment_command.rb
> install -c -m 0644 rubygems/commands/fetch_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/fetch_command.rb
> install -c -m 0644 rubygems/commands/generate_index_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/generate_index_command.rb
> install -c -m 0644 rubygems/commands/help_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/help_command.rb
> install -c -m 0644 rubygems/commands/install_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/install_command.rb
> install -c -m 0644 rubygems/commands/list_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/list_command.rb
> install -c -m 0644 rubygems/commands/lock_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/lock_command.rb
> install -c -m 0644 rubygems/commands/mirror_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/mirror_command.rb
> install -c -m 0644 rubygems/commands/outdated_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/outdated_command.rb
> install -c -m 0644 rubygems/commands/owner_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/owner_command.rb
> install -c -m 0644 rubygems/commands/pristine_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/pristine_command.rb
> install -c -m 0644 rubygems/commands/push_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/push_command.rb
> install -c -m 0644 rubygems/commands/query_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/query_command.rb
> install -c -m 0644 rubygems/commands/rdoc_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/rdoc_command.rb
> install -c -m 0644 rubygems/commands/search_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/search_command.rb
> install -c -m 0644 rubygems/commands/server_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/server_command.rb
> install -c -m 0644 rubygems/commands/setup_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/setup_command.rb
> install -c -m 0644 rubygems/commands/sources_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/sources_command.rb
> install -c -m 0644 rubygems/commands/specification_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/specification_command.rb
> install -c -m 0644 rubygems/commands/stale_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/stale_command.rb
> install -c -m 0644 rubygems/commands/uninstall_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/uninstall_command.rb
> install -c -m 0644 rubygems/commands/unpack_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/unpack_command.rb
> install -c -m 0644 rubygems/commands/update_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/update_command.rb
> install -c -m 0644 rubygems/commands/which_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/which_command.rb
> install -c -m 0644 rubygems/commands/yank_command.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ommands/yank_command.rb
> install -c -m 0644 rubygems/compatibility.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ompatibility.rb
> install -c -m 0644 rubygems/config_file.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
onfig_file.rb
> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ore_ext
> install -c -m 0644 rubygems/core_ext/kernel_gem.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ore_ext/kernel_gem.rb
> install -c -m 0644 rubygems/core_ext/kernel_require.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/c=
ore_ext/kernel_require.rb
> install -c -m 0644 rubygems/defaults.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/d=
efaults.rb
> install -c -m 0644 rubygems/dependency.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/d=
ependency.rb
> install -c -m 0644 rubygems/dependency_installer.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/d=
ependency_installer.rb
> install -c -m 0644 rubygems/dependency_list.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/d=
ependency_list.rb
> install -c -m 0644 rubygems/dependency_resolver.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/d=
ependency_resolver.rb
> install -c -m 0644 rubygems/deprecate.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/d=
eprecate.rb
> install -c -m 0644 rubygems/doctor.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/d=
octor.rb
> install -c -m 0644 rubygems/errors.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
rrors.rb
> install -c -m 0644 rubygems/exceptions.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xceptions.rb
> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xt
> install -c -m 0644 rubygems/ext/builder.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xt/builder.rb
> install -c -m 0644 rubygems/ext/cmake_builder.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xt/cmake_builder.rb
> install -c -m 0644 rubygems/ext/configure_builder.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xt/configure_builder.rb
> install -c -m 0644 rubygems/ext/ext_conf_builder.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xt/ext_conf_builder.rb
> install -c -m 0644 rubygems/ext/rake_builder.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xt/rake_builder.rb
> install -c -m 0644 rubygems/ext.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/e=
xt.rb
> install -c -m 0644 rubygems/gem_runner.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/g=
em_runner.rb
> install -c -m 0644 rubygems/gemcutter_utilities.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/g=
emcutter_utilities.rb
> install -c -m 0644 rubygems/indexer.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/i=
ndexer.rb
> install -c -m 0644 rubygems/install_message.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/i=
nstall_message.rb
> install -c -m 0644 rubygems/install_update_options.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/i=
nstall_update_options.rb
> install -c -m 0644 rubygems/installer.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/i=
nstaller.rb
> install -c -m 0644 rubygems/installer_test_case.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/i=
nstaller_test_case.rb
> install -c -m 0644 rubygems/local_remote_options.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/l=
ocal_remote_options.rb
> install -c -m 0644 rubygems/mock_gem_ui.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/m=
ock_gem_ui.rb
> install -c -m 0644 rubygems/name_tuple.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/n=
ame_tuple.rb
> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage
> install -c -m 0644 rubygems/package/digest_io.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/digest_io.rb
> install -c -m 0644 rubygems/package/old.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/old.rb
> install -c -m 0644 rubygems/package/tar_header.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/tar_header.rb
> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/tar_reader
> install -c -m 0644 rubygems/package/tar_reader/entry.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/tar_reader/entry.rb
> install -c -m 0644 rubygems/package/tar_reader.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/tar_reader.rb
> install -c -m 0644 rubygems/package/tar_test_case.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/tar_test_case.rb
> install -c -m 0644 rubygems/package/tar_writer.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage/tar_writer.rb
> install -c -m 0644 rubygems/package.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage.rb
> install -c -m 0644 rubygems/package_task.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ackage_task.rb
> install -c -m 0644 rubygems/path_support.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
ath_support.rb
> install -c -m 0644 rubygems/platform.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
latform.rb
> install -c -m 0644 rubygems/psych_additions.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
sych_additions.rb
> install -c -m 0644 rubygems/psych_tree.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/p=
sych_tree.rb
> install -c -m 0644 rubygems/rdoc.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/r=
doc.rb
> install -c -m 0644 rubygems/remote_fetcher.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/r=
emote_fetcher.rb
> install -c -m 0644 rubygems/request_set.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/r=
equest_set.rb
> install -c -m 0644 rubygems/requirement.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/r=
equirement.rb
> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ecurity
> install -c -m 0644 rubygems/security/policies.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ecurity/policies.rb
> install -c -m 0644 rubygems/security/policy.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ecurity/policy.rb
> install -c -m 0644 rubygems/security/signer.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ecurity/signer.rb
> install -c -m 0644 rubygems/security/trust_dir.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ecurity/trust_dir.rb
> install -c -m 0644 rubygems/security.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ecurity.rb
> install -c -m 0644 rubygems/server.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
erver.rb
> install -c -m 0644 rubygems/source.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ource.rb
> install -c -m 0644 rubygems/source_list.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ource_list.rb
> install -c -m 0644 rubygems/source_local.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ource_local.rb
> install -c -m 0644 rubygems/source_specific_file.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
ource_specific_file.rb
> install -c -m 0644 rubygems/spec_fetcher.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
pec_fetcher.rb
> install -c -m 0644 rubygems/specification.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
pecification.rb
> install -c -m 0644 rubygems/syck_hack.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
yck_hack.rb
> install -c -m 0644 rubygems/test_case.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/t=
est_case.rb
> install -c -m 0644 rubygems/test_utilities.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/t=
est_utilities.rb
> install -c -m 0644 rubygems/text.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/t=
ext.rb
> install -c -m 0644 rubygems/uninstaller.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/u=
ninstaller.rb
> install -c -m 0644 rubygems/user_interaction.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/u=
ser_interaction.rb
> install -c -m 0644 rubygems/validator.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/v=
alidator.rb
> install -c -m 0644 rubygems/version.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/v=
ersion.rb
> install -c -m 0644 rubygems/version_option.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/v=
ersion_option.rb
> install -c -m 0644 rubygems.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems.r=
b
> install -c -m 0644 ubygems.rb=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/ubygems.rb=

> mkdir -p=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
sl_certs
> install -c -m 0644 rubygems/ssl_certs/AddTrustExternalCARoot.pem=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
sl_certs/AddTrustExternalCARoot.pem
> install -c -m 0644=20
> =
rubygems/ssl_certs/Entrust_net-Secure-Server-Certification-Authority.pem=20=

> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
sl_certs/Entrust_net-Secure-Server-Certification-Authority.pem
> install -c -m 0644 rubygems/ssl_certs/GeoTrust_Global_CA.pem=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
sl_certs/GeoTrust_Global_CA.pem
> install -c -m 0644=20
> =
rubygems/ssl_certs/VerisignClass3PublicPrimaryCertificationAuthority-G2.pe=
m=20
> =
/Users/7stud/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/s=
sl_certs/VerisignClass3PublicPrimaryCertificationAuthority-G2.pem
> install -c -m 0755=20
> /var/folders/++/++iEr0qoGaimgUBsnNcijk+++TI/-Tmp-/gem.33469=20
> /Users/7stud/.rvm/rubies/ruby-2.0.0-p0/bin/gem
> rm /var/folders/++/++iEr0qoGaimgUBsnNcijk+++TI/-Tmp-/gem.33469
> ERROR:  While executing gem ... (NoMethodError)
>    undefined method `fu_stream_blksize' for=20
> #<Gem::Commands::SetupCommand:0x00000101864280>
> Installing RubyGems
> Installing gem executable
>=20
> --=20
> Posted via http://www.ruby-forum.com/.
>=20