Hans Mackowiak wrote in post #1101208:
> what is the ruby version of the new server? you may miss some gem
> installed
>
>
>
> gem install yaml

Thanks for your reply

ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [x86_64-linux]

gem -v
1.0.1

I copied entire binary from old machine to new one, so assume all is 
good.

I tried to do gem install yaml

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require': no such file to load -- zlib (LoadError)
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:10
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:9
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:11
         ... 11 levels...
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:103:in 
`process_args'
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:74:in 
`run'
        from 
/usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:in `run'
        from /usr/local/bin/gem:22
xmargind@nygeqdbxmgdev01:/export/applications/datasynapse/ruby/internalapps/shared_infra/compiled/bin>

-- 
Posted via http://www.ruby-forum.com/.