does not work, because autoload use require, not require_relative, your 
`mylibrary.rb` is not in the LOAD_PATH, so the normal require cant find 
it, thats why autoload does not work..

but as you can see, the accessing of an non-existing constant does 
result in an require

-- 
Posted via http://www.ruby-forum.com/.