Hi Carlo and all,

On 27.02.2013, at 10:45, Carlo E. Prelz <fluido / fluido.as> wrote:

> 	Subject: Mac OS 10.8.2 and openssl
> 	Date: mer 27 feb 13 06:32:24 +0900
>=20
> Quoting Dr. Hegewald (hegewald / irmb.tu-bs.de):
>=20
>> Then I want to install my gems as usual:
>> $ gem install terminal-notifier
>> ERROR:  Loading command: install (LoadError)
>> 	cannot load such file -- openssl
>> ERROR:  While executing gem ... (NoMethodError)
>>    undefined method `invoke_with_build_args' for nil:NilClass
>=20
> If you compile from source, try to go to <path_of_source>/ext/openssl,
> and type this:
>=20
> ruby extconf.rb

that does not seem to work:

$ ruby extconf.rb
checking for t_open() in -lnsl... no
checking for socket() in -lsocket... no
checking for assert.h... yes
checking for openssl/ssl.h... yes
checking for OpenSSL_add_all_digests() in -lcrypto... yes
checking for SSL_library_init() in -lssl... yes
checking for openssl/conf_api.h... yes
checking for SSL_library_init() in openssl/ssl.h with =
-Werror=3Ddeprecated-declarations... no
extconf.rb:62:in `<main>': Ignore OpenSSL broken by Apple. =
(RuntimeError)
Please use another openssl. (e.g. using `configure =
--with-openssl-dir=3D/path/to/openssl')

So do I really have to install another openssl? If I do so, can I =
exclude it from my $PATH, as it is set via --with-openssl-dir ?

Cheers,
Jan