Here's the output. But i already done these. Still no luck.

Requirements for ubuntu/12.10/i386

NOTE: 'ruby' represents Matz's Ruby Interpreter (MRI) (1.8.X, 1.9.X)
             This is the *original* / standard Ruby Language Interpreter
      'ree'  represents Ruby Enterprise Edition
      'rbx'  represents Rubinius

Additional Dependencies:
# For update-system:
sudo apt-get update

# For rvm:
sudo apt-get --no-install-recommends install bash curl git patch bzip2

# For ruby:
sudo apt-get --no-install-recommends install build-essential openssl 
libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev 
libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf 
libc6-dev libgdbm-dev ncurses-dev automake libtool bison subversion 
pkg-config libffi-dev

# For jruby:
sudo apt-get --no-install-recommends install curl g++ 
openjdk-6-jre-headless

-- 
Posted via http://www.ruby-forum.com/.