This is perhaps not totally resolved. Though ruby -v says 1.9, I'm not 
sure that's what's actually running. I was expecting that the scope of a 
local variable would not override that of a block variable, but it has, 
which I understand changed with 1.9. Is there some way I can know which 
version is actually running?

Also, when i look in the Library/Ruby directory, there is only a 1.8 
folder . . .?

-- 
Posted via http://www.ruby-forum.com/.