On 12/28/12, John Sampson <jrs.idx / ntlworld.com> wrote:
> On 28/12/2012 10:10, Rocky Bernstein wrote:
>> ruby-debug on Windows and 1.9.x is a problem many people have. If you
>> want strictly ruby-debug for Ruby 1.9.x the package you are looking for
>> is ruby-debug19, not ruby-debug.
>>
>>
> [snip]
>
> Thanks for the info.
>
> Ruby-debug19 doesn't install either.


failure message?

>
> I don't necessarily want ruby-debug but it is the debugger covered in
> the Pickaxe book
> which describes Ruby 1.9.
>
> Perhaps Windows programmers are seen as too intelligent to need debuggers.
>
> Meanwhile, is DevKit-4.5.0-20100819-1536-sfx.exe an appropriate version for
> the current version of Ruby? I downloaded it from a third-party website.

That should work, you can get a slightly newer version at rubyinstaller.org