You are right - I'm working with OSX 10.6.8 and develop my scripts in 
eclipse with jruby.
With JRuby 1.6.8 my solution works.
With the native Ruby 1.8.7 it doesn't.

Your solution works with ruby, jruby, on windows and on osx.

Al

-- 
Posted via http://www.ruby-forum.com/.