On Dec 5, 2012, at 01:27 , Mallikarjuna Yaddala <lists / ruby-forum.com> =
wrote:

> Hi All,
>=20
> I have installed two different versions of a gem (1.0.0 and 1.0.4)
>=20
>=20
> My code :
>=20
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D
>=20
> require 'test' , '>=3D 1.3.6'

require doesn't take 2 args (as it doesn't makes sense to be able to =
require across 2+ versions of the same gem). =46rom the rdoc:

	% ri require
	...
	=3D=3D=3D Implementation from Kernel
	=
--------------------------------------------------------------------------=
----
	  require(string)    =3D> true or false
	...

You want to specify that at the gem level using #gem:

	% ri gem
	...
	(from gem rubygems-1.8.24)
	=3D=3D=3D Implementation from Kernel
	=
--------------------------------------------------------------------------=
----
	  gem(gem_name, *requirements)
	...

So you want:

	gem "test", ">=3D 1.3.6" # assuming the gem name is actually =
"test"
	require "test"         # assuming there is a file "test.rb" in =
the gem

BUT... also note that your version specifier above will NOT match either =
version you have installed.=